Contact Form For Mephisto updated for Drax 0.8

Mephisto Drax (version 0.8) introduces breaking changes for plugins. I've just finished updating the contact / feedback form plugin. It's now working fine and tests passing.

Installation instructions are the same as before except that the 'contact_notifier' has moved from the 'lib' directory to the 'app' directory. It still needs to be updated to include your destination email address for contact mails.

If you're a Mephisto plug-in developer, you might be interested in checking out my post on migrating Mephisto plugins to Drax. It's based on my experiences with the contact_form.


Actions

Information

6 responses to “Contact Form For Mephisto updated for Drax 0.8”

25 08 2008
James Crisp - C#, JRuby, Ruby on Rails, .NET, book reviews, film reviews, mind hacks, Wing Chun and the occasional personal bit. » Contact / Feedback Form Plugin for Mephisto (15:27:58) :

[...] UPDATE Please check out information about using the contact form plugin with Mephisto Drax 0.8. [...]

6 01 2009
Maksym Samadov (14:22:36) :

James,

I tried to install the contact form plugin, but after restart my server hosted on mediatemple stopped working (502 Bad Gateway). I removed the plugin, but getting this error (see below).
Do you think it may be related to the plugin? I run ruby 1.8.5 and installed the new version of the plugin in vendors/plugin via ssh.

application failed to start, check /home/14802/containers/rails/cirrus/log/mongrel.log for errors return code: 8 output: ** Ruby version is not up-to-date; loading cgi_multipart_eof_fix /home/14802/data/rubygems/gems/gems/mongrel-1.1.1-mswin32/bin/../lib/http11.so: /home/14802/data/rubygems/gems/gems/mongrel-1.1.1-mswin32/bin/../lib/http11.so: invalid ELF header - /home/14802/data/rubygems/gems/gems/mongrel-1.1.1-mswin32/bin/../lib/http11.so (LoadError) from /home/14802/data/rubygems/local/lib/site_ruby/1.8/rubygems/custom_require.rb:32:in `require' from /home/14802/data/rubygems/gems/gems/mongrel-1.1.1-mswin32/bin/../lib/mongrel.rb:16 from /home/14802/data/rubygems/local/lib/site_ruby/1.8/rubygems/custom_require.rb:32:in `gem_original_require' from /home/14802/data/rubygems/local/lib/site_ruby/1.8/rubygems/custom_require.rb:32:in `require' from /home/14802/data/rubygems/gems/gems/mongrel-1.1.1-mswin32/bin/mongrel_rails:11 from /home/14802/data/rubygems/gems/bin/mongrel_rails:16:in `load' from /home/14802/data/rubygems/gems/bin/mongrel_rails:16

9 01 2009
James (10:34:48) :

Hi Maksym, not 100% sure, but I think you may need to upgrade to ruby 1.8.6. James

10 08 2009
Michael (09:57:17) :

Thanks for the great plugin. Just wanted to post a followup since I'm using Rails 2.2.2, Ruby 1.8.6 and received "error outputting tainted string" while sending emails. I corrected by introducing the helpers round the output as such:


From: )
Subject:

10 08 2009
Michael (10:00:00) :

Looks like my last post didn't show the code, but if anyone has the same issue, update /vendor/gems/plugins/mephisto_contact_form/app/views/contact_notifier/contact_notification.rhtml/erb

and wrap output expressions with the "h" helper.

10 08 2009
James (10:11:57) :

Hi Michael,

Sorry for the outdated info here, I've actually moved the contact form plugin code across to github..

http://github.com/jcrisp/mephisto_contact_form/tree/master

The last commit was actually fixing the tainted string issue 🙂